アフィリエイト・アドセンス広告を利用しています。詳細は こちら



NEC 業務用ルーター UNIVERGE IX2215(中古)自宅用ルーター IPv4 PPPoE ネットワーク設定メモ

前回の記事 では中古で複数台安く入手することができた NEC 業務用ルーター UNIVERGE IX2215 の稼働や設定するのに、必要な備品と設置するのに工夫した内容を紹介しました。

今回の記事では UNIVERGE IX2215 の初期設定および IPv4 PPPoE 環境下でのネットワーク設定方法を紹介します。

NEC 業務用ルーター UNIVERGE IX2215(中古)自宅用ルーター IPv4 PPPoE ネットワーク設定メモ


NEC UNIVERGE IX2215 初期設定

NEC 業務用ルーター UNIVERGE IX2215(中古)自宅用ルーター IPv4 PPPoE ネットワーク設定メモ

UNIVERGE IX シリーズ UNIVERGE IX2215 の基本的な初期設定やネットワークの設定方法については、公式が用意している UNIVERGE IX シリーズマニュアル実機演習資料(初級編)~UNIVERGE IX2215~ があるのでまずはそちらを読むことになります。

家庭用ルーターとは違い膨大なマニュアルや資料・設定事例集から、さまざまなネットワーク設定ができるように網羅されています。

以下、今回 UNIVERGE IX2215 の初期設定やネットワーク設定に参照した PDF マニュアルリストです。

  • 実機演習資料(初級編)~UNIVERGE IX2215~(ix2k3k-learning-Ver.10.2_20.1.pdf)
  • 取扱説明書(UM-IX2000-ver10.7-1.pdf)
  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
  • Web 設定マニュアル(WM-ver10.7-1.pdf)
  • 機能説明書(FD-ver10.7.pdf)
  • 設定事例集(IX1-3K-EX-10.7.pdf)

内容が豊富な各種 PDF マニュアルですが目的の機能を設定したい場合に、未経験ユーザーが膨大なマニュアルページ数の中から検索して探したり、手探りで設定をして試行錯誤や動作確認するのはかなり大変です。

この記事ではどのマニュアルのどのページを参照して初期設定や各種設定、IPv4 PPPoE ネットワーク設定などを行ったかを、各セクションごとに記録しておきました。

なお、PDF マニュアルは公式が定期的にバージョンが更新されてページ数が変動することがあるので、その場合は参照したページ数がズレてしまうことがあります。

UNIVERGE IX シリーズの新旧機種の発売サイクルにより、年数の経過した機種が中古でユーザーに行き渡っているおかげか、ネットで先人による設定方法が紹介されています。そういった情報も頼りにすることで手探りで試行錯誤する労力を最小限に済ませることができます。

NEC UNIVERGE IX2215 - CLI(コマンドラインインタフェース)基本操作

UNIVERGE IX シリーズで設定するうえで外せないのが CLI(コマンドラインインタフェース)による基本的な操作と、よく使うコマンドや管理上必要なコマンドがあります。

以下のマニュアルおよびサイト先でほぼ網羅できますので、初めて CLI(コマンドラインインタフェース)を触るのであれば操作方法や一連の設定方法を確認しておきましょう。

コマンド操作するうえでコマンド内容に応じたコンフィグモード(グローバルコンフィグモード、インタフェースコンフィグモード、デバイスコンフィグモードなど)の切り替えが必要です。

コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)の各コマンドに「実行モード」項目があり、そこにコマンドを実行する時のコンフィグモードが明記されています。

  • 実機演習資料(初級編)~UNIVERGE IX2215~(ix2k3k-learning-Ver.10.2_20.1.pdf)
    • (1)基本操作(IX2215)
      • コマンド入力について(10 ページ)
      • モード以降のイメージ(15 ページ)
      • コンフィグモードへの移行(16 ページ)
      • 設定の削除(コマンドの削除)(27 ページ)
      • コンフィグの保存(28 ページ)
      • 設定情報の表示(1)(31 ページ)
      • 簡易ミス防止(33 ページ)
  • 取扱説明書(UM-IX2000-ver10.7-1.pdf)
    • 3 基本操作と各種説明
      • 設定モードについて 3-2(204 ページ)
      • コマンド入力について 3-9(211 ページ)
      • モードについて 3-15(217 ページ)
      • ログインとユーザー権限について 3-20(222 ページ)
      • ソフトウェアと設定データ 3-24(226 ページ)
  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 1. オペレーションモード編 - オペレーションモード - コマンド一覧 1-2(8 ページ)
    • 2. グローバルコンフィグ編 - グローバルコンフィグ
      • コンフィグの保存(入力形式 write memory) 2-13(25 ページ)
      • ランニングコンフィグレーションの表示(入力形式 show running-config) 2-16(28 ページ)
      • スタートコンフィグレーションの表示(入力形式 show startup-config) 2-16(28 ページ)
    • 32. 保守編
      • コンフィグレーションチェック - コンフィグレーションチェック(入力形式 check configuration) 32-62(803 ページ)
      • ブートコンフィグ - ファイル/コンフィグファイル/装置情報のコピー(入力形式 copy running-config { default-config | startup-config }) 32-12(753 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定 - 2.1 基本操作 2-1(49 ページ)

また、デバイス設定(物理インタフェース)とインタフェース設定(論理インタフェース・・・基本インタフェース(IP 設定)とサブインタフェース(PPPoE / VLAN 設定))があります。以下の deviceinterface コマンドでインタフェースコンフィグモードに移行してから設定します。ここを間違えると意図したネットワーク設定ができなかったり接続がうまくいきません。

UNIVERGE IX2215 の場合、インタフェース名が GigaEthernet0 ~ GigaEthernet2 の 3つがあります。それぞれポート番号で GigaEthernet0 ・・・ GE0 ポート、GigaEthernet1 ・・・ GE1 ポート、GigaEthernet2 ・・・ GE2 ポート(SW-HUB)に対応しています。

  • 実機演習資料(初級編)~UNIVERGE IX2215~(ix2k3k-learning-Ver.10.2_20.1.pdf)
    • (1)基本操作(IX2215)
      • LAN インタフェースの設定(1)(22 ページ)
      • LAN インタフェースの設定(3)(24 ページ)
  • 取扱説明書(UM-IX2000-ver10.7-1.pdf)
    • 3 基本操作と各種説明
      • モードについて - インタフェース表示の意味 3-16(218 ページ)
    • 4 初期設定の方法 - リモートコンソールのための設定
      • 1 IP アドレスの設定とインタフェースの有効化 4-17(249 ページ)
      • 2 IP アドレスの確認 4-18(250 ページ)
  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 3. インタフェース編 - インタフェース
      • デバイスコンフィグモードへの移行(入力形式 device DEVICE-NAME) 3-4(36 ページ)
      • インタフェースコンフィグモードへの移行(入力形式 interface INTERFACE-NAME) 3-5(37 ページ)
      • インタフェース停止(入力形式 shutdownno shutdown) 3-6(38 ページ)
    • 8. IPv4 編 - IPv4 - インタフェースアドレス設定(入力形式 ip address) 8-9(160 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定 - 2.16 IPv4 の設定 2-183(231 ページ)

NEC UNIVERGE IX2215 - スーパーリセット

NEC 業務用ルーター UNIVERGE IX2215(中古)自宅用ルーター IPv4 PPPoE ネットワーク設定メモ、NEC UNIVERGE IX2215 初期設定、NEC UNIVERGE IX2215 - スーパーリセット、NEC UNIVERGE IX2215 のコンソールポート(CONSOLE)に USB コンソールケーブル接続後電源投入、Tera Term を起動して Serial(Port: COM3: USB Serial Port (COM3))を選択して OK ボタンをクリック、Router# が表示されてキーボードの Enter キーで反応が確認できたらルーター背面の電源スイッチ電源切り入りで再起動、ファームウェアローディング中に Ctrl + C で強制停止を行いコマンドプロンプト画面で cc を入力、次に Y を入力して初期化開始、初期化完了後 b を入力してルーター再起動

UNIVERGE IX シリーズを中古で入手した場合にほぼ確実にスーパーリセットを行うことになります。

このスーパーリセットの手順はすでに個人ブログや動画で公開されているので、参考サイトのリンク先に記載している手順通りに進めれば迷うことはないかと思います。

スーパーリセットを行うには USB コンソールケーブルの入手と設定を行う PC へのドライバーのインストール、ターミナルエミュレータを使用します。ここではターミナルエミュレータとして Tera Term を例に説明します。

UNIVERGE IX2215 のコンソールポート(CONSOLE)に USB コンソールケーブル 接続後電源を投入します。

Tera Term を起動して Serial(Port: COM3: USB Serial Port (COM3)) を選択して OK ボタンをクリックします。

うまくいくと画面に Router# が表示されます。キーボードの Enter キーで反応が確認できたら、ルーター背面の電源スイッチ切り入りで再起動します。

ファームウェアローディング中に Ctrl + C で強制停止を行い、コマンドプロンプト画面で cc を入力します。

次に Y を入力して初期化を開始、初期化完了後 b を入力してルーターを再起動します。

以上がスーパーリセットの手順となります。

ちなみにコンソール画面にはハードウェア自己診断の結果が表示されますが、中古で入手した場合 NVRAM TEST: Fail と表示されることがあるようです。

これは内部に取り付けられている電池に関するエラーで、解消するには新しい電池を購入して交換することになります。電池は 1個当たりの単価が高く(1個 1,000円前後?)国内での入手経路が限られるということもあり、手軽に入手できないところが難点です。

  • 実機演習資料(初級編)~UNIVERGE IX2215~(ix2k3k-learning-Ver.10.2_20.1.pdf)
    • (1)基本操作(IX2215)
      • コンソール端末の接続(7 ページ)
      • 電源の投入(ハードウェア自己診断)(8 ページ)
      • ソフトウェアの起動(9 ページ)
      • スーパーリセット(30 ページ)
  • 取扱説明書(UM-IX2000-ver10.7-1.pdf)
    • 4 初期設定の方法 - ご購入後の基本的な設定 4-2(234 ページ)
    • 6 管理と保守 - スーパーリセット 6-35(319 ページ)
  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 32. 保守編 - ブートモニタ
      • スタートアップコンフィグのクリア(入力形式 cc) 32-5(746 ページ)
      • 実行プログラムの起動(入力形式 b) 32-5(746 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定 - 2.1 基本操作 - 2.1.7 スーパーリセット 2-7(55 ページ)

NEC UNIVERGE IX2215 - ルーターホスト名、ログイン名とパスワード設定

以下のコマンドでルーターのホスト名、ログイン名とパスワードの設定をします。

後で変更できるので、ここではとりあえずルーターの設定を行うためにシンプルなものにしておきます。

Web コンソール有効化 するときにここで設定したログイン名とパスワードを入力します。

NEC UNIVERGE IX2215 - ホスト名・ログイン名とパスワード設定コマンド
hostname HOSTNAME
username USER-NAME password { plain [MODE] | hash } PASSWORD [LEVEL]

なお、コマンド書式の パラメーターの英字が大文字 となっているものは、ユーザーが任意の名前で入力設定するもの、決められた範囲内の数値や文字を入力して指定・設定するもの、ISP や NetMeister から提供された ID・パスワードを入力して設定するものなどがあります。

また、波かっこ { } 内のパラメーターについてはパイプ文字 | で区切られた文字のいずれかを必ず入力。大かっこ [ ] 内のパラメーターについては決められた範囲内の数値や文字などを入力して指定しますが、省略した場合はデフォルト値が設定されます。

例えばログイン名とパスワード設定コマンドで { plain [MODE] | hash } とありますが、この場合はパイプ文字 | で区切られた plain もしくは hash いずれかの入力が必須です。

さらに plain の場合は [MODE] 部分に数値を指定することで plain 0 なら「旧方式でハッシュ化」、plain 1 なら「新方式でハッシュ化」を設定します。plain のまま数値を省略した場合はデフォルト値の 1(新方式でハッシュ化)で設定されます。

コマンドの書式やパラメーターの詳細、デフォルト値や入力例については コマンドリファレンスマニュアル に詳しく記載されています。

この記事では コマンドリファレンスマニュアル にある「入力形式」の内容を記載していますが、コマンドが長いものについては一部省略しています。

  • 実機演習資料(初級編)~UNIVERGE IX2215~(ix2k3k-learning-Ver.10.2_20.1.pdf)
    • (1)基本操作(IX2215)
      • ホスト名の設定(19 ページ)
      • ログイン名の設定(20 ページ)
  • 取扱説明書(UM-IX2000-ver10.7-1.pdf)
    • 3 基本操作と各種説明 - ログインとユーザ権限 3-20(222 ページ)
  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 2. グローバルコンフィグ編
      • ホスト名の設定(入力形式 hostname HOSTNAME) 2-4(16 ページ)
      • ユーザの追加/削除(入力形式 username USER-NAME password { plain [MODE] | hash } PASSWORD) 2-12(24 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定 - 2.2 システムの設定 2-9(57 ページ)
    • 2章 ルータの設定 - 2.43 Web コンソールの設定 - 2.43.8 詳細設定
      • 2.43.8.1 パスワードの設定 2-598(646 ページ)
      • 2.43.8.2 装置名の設定 2-599(647 ページ)

NEC UNIVERGE IX2215 - IP アドレス / サブネットマスク長設定

以下のコマンドでルーターに IP アドレス / サブネットマスク長のネットワーク設定します。

Telnet サーバWeb コンソール でルータにアクセスするのに必要になります。

NEC UNIVERGE IX2215 - IP アドレス設定コマンド
interface GigaEthernet2.0
  ip address 192.168.xxx.xxx/24
  no shutdown
  • 実機演習資料(初級編)~UNIVERGE IX2215~(ix2k3k-learning-Ver.10.2_20.1.pdf)
    • (1)基本操作(IX2215)
      • LAN インタフェースの設定(1)(22 ページ)
      • LAN インタフェースの設定(3)(24 ページ)
      • Ping による疎通の確認(26 ページ)
    • (2)演習 1 PPPoE 回線でのインターネット接続 - LAN インタフェースの設定(45 ページ)
  • 取扱説明書(UM-IX2000-ver10.7-1.pdf)
    • 4 初期設定の方法 - リモートコンソールのための設定
      • 1 IP アドレスの設定とインタフェースの有効化 4-17(249 ページ)
      • 2 IP アドレスの確認 4-18(250 ページ)
  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 3. インタフェース編 - インタフェース
      • インタフェースコンフィグモードへの移行(入力形式 interface INTERFACE-NAME) 3-5(37 ページ)
      • インタフェース停止(入力形式 shutdownno shutdown) 3-6(38 ページ)
    • 8. IPv4 編 - IPv4 - インタフェースアドレス設定(入力形式 ip address) 8-9(160 ページ)
  • Web 設定マニュアル(WM-ver10.7-1.pdf)
    • 4. 詳細設定 - 4.2 LAN - 4.2.1 LAN アドレスの設定 4-19(214 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定 - 2.16 IPv4 の設定 2-183(231 ページ)

NEC UNIVERGE IX2215 - Telnet サーバ有効化

以下のコマンドでルーターの Telnet サーバを有効化できます。

NEC UNIVERGE IX2215 - Telnet サーバ有効化コマンド
telnet-server ip enable

Telnet サーバ有効化後、GE2(SW-HUB)ポートに LAN ケーブルを接続。ルーターと PC が同じネットワーク設定内にあれば、Tera Termルーターに設定した IP アドレス を指定することで、USB コンソールケーブル がなくても LAN 上でルーターの設定ができるようになります。

NEC 業務用ルーター UNIVERGE IX2215(中古)自宅用ルーター IPv4 PPPoE ネットワーク設定メモ、NEC UNIVERGE IX2215 初期設定、NEC UNIVERGE IX2215 - Telnet サーバ有効化、Telnet サーバ有効化後 Tera Term を起動して TCP/IP の Host にルーターの IP アドレスを指定、Service: を Telnet に設定して OK ボタンをクリックして接続を確認

Tera Term での Telnet 接続方法は、Tera Term を起動して TCP/IP の Host に ルーターに設定した IP アドレス を指定、Service: を Telnet に設定して OK ボタンをクリックすることで接続できます。

  • 実機演習資料(初級編)~UNIVERGE IX2215~(ix2k3k-learning-Ver.10.2_20.1.pdf)
    • (1)基本操作(IX2215) - リモートコンソール(Telnet サーバ)(36 ページ)
  • 取扱説明書(UM-IX2000-ver10.7-1.pdf)
    • 4 初期設定の方法 - リモートコンソールのための設定 - 3 telnet サーバの起動 4-19(251 ページ)
  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 32. 保守編 - telnet - IPv4 telnet サーバ起動・停止(入力形式 telnet-server ip enable) 32-39(780 ページ)
  • Web 設定マニュアル(WM-ver10.7-1.pdf)
    • 4. 詳細設定 - 4.1 基本設定 - 4.1.4 保守の設定 4-10(205 ページ)

NEC UNIVERGE IX2215 - Web コンソール有効化

以下のコマンドでルーターの Web コンソールを有効化します。

NEC UNIVERGE IX2215 - Web コンソール有効化コマンド
http-server ip enable
http-server username USER-NAME

USER-NAME設定したログイン名 です。

Web コンソールを有効化することで、家庭用ルーターと同じくブラウザ上からルーターの設定や各種状態を確認することができます。ただ、コマンド入力による細かい設定まではできないので、設定したい内容によってはコマンド入力は必要になります。

UNIVERGE IX2215 ではブラウザから管理画面にアクセスした際に「任意コマンドの実行」というメニューがあります。ここから各種コマンドの入力・実行ができます。

これにより Tera Term などのターミナルエミュレータを使わなくても、ブラウザ上でのコマンド実行によるルーターの設定・保守管理が可能となります。

ただし、一部のコマンドは実行できないとの明記(機能説明書(FD-ver10.7.pdf) - 2章 ルータの設定 - 2.43 Web コンソールの設定 - 2.43.6.8 任意コマンドの実行 2-595(643 ページ))があります。

  • 実機演習資料(初級編)~UNIVERGE IX2215~(ix2k3k-learning-Ver.10.2_20.1.pdf)
    • (1)基本操作(IX2215) - Web コンソール(37 ページ)
  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 27. HTTP サーバ編 - http
      • IPv4 http 機能の有効化(入力形式 http-server ip enable) 27-5(701 ページ)
      • ユーザの指定(入力形式 http-server username USER-NAME) 27-8(704 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定 - 2.43 Web コンソールの設定 2-587(635 ページ)

NEC UNIVERGE IX2215 各種設定

UNIVERGE IX2215 の初期設定 完了後、ネットワークおよびインターネットへ接続するための IPv4 PPPoE 設定を行います。

基本的に過去に購入したルーターの置き換えになるので、以下のセクションではその設定をほぼ引き継ぐ形での設定内容となります。

NEC UNIVERGE IX2215 - ファームウェア更新

中古で入手した業務用ルーターであれば大半は安定稼働のため、ファームウェアのアップデートはやっておらず、(出荷時の)初期ファームウェアのままのパターンがほとんどかと思います。

個人で使うとなると新しいファームウェアによるセキュリティ強化やバグフィックス・新機能追加など気になるところがあるので、長く稼働させるためにも家庭用ルーターでやっていた時と同じように、ファームウェアのアップデートをやっておくことにします。

UNIVERGE シリーズのファームウェアを入手するには、申請書による書面での手続きでログイン ID とパスワードを発行してもらい、専用サイトにアクセスしてファイルをダウンロードする必要があります。

2024/1/18 追記

申請書による手続きをしなくても UNIVERGE IX シリーズのファームウェアがダウンロードできる ようになっていました。

以下の参考サイトの情報により個人でも申請手続きが可能とあったので、その内容に従って申請を行い無事ファームウェアをダウンロードすることができました。

UNIVERGE シリーズのファームウェアの更新方法はいくつか用意されています。今回は Web コンソール有効化 後ブラウザ上の管理画面にある「ソフトウェアの更新」から、ファームウェアのファイル(.rap ファイル)を指定してアップデートを行います。

最新ファームウェアアップデート後であれば NetMeister に登録することで、オンライン上でルーターの保守管理ができるほかにファームウェアの直接アップデートが可能になります。

  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 32. 保守編 - ソフトウェア更新 - コマンド一覧 32-67(808 ページ)
  • Web 設定マニュアル(WM-ver10.7-1.pdf)
    • 6 保守管理 - 6.5 ソフトウェアの更新 6-18(387 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 10章 ファームウェアインストール 10-1(1019 ページ)

NEC UNIVERGE IX2215 - 任意コマンドの実行

UNIVERGE IX2215Web コンソール有効化 後は、ブラウザでルーターの管理画面にアクセスして、管理メニューにある「任意コマンドの実行」で各種コマンドの入力・実行することで設定や保守管理が可能になります。

一度にたくさんのコマンドを実行したい場合にも、まとめて入力してから実行できます。この辺はターミナルエミュレータと同じです。ちなみに NetMeister 上からでもコマンド実行ができます。

ただし、一部のコマンドは実行できないとの明記(機能説明書(FD-ver10.7.pdf) - 2章 ルータの設定 - 2.43 Web コンソールの設定 - 2.43.6.8 任意コマンドの実行 2-595(643 ページ))があるので、そのような場合は Tera TermUSB コンソールケーブル or Telnet)を使ってコマンド実行・設定することになります。

  • Web 設定マニュアル(WM-ver10.7-1.pdf)
    • 2. メニュー - 2.4 設定の保存 2-12(50 ページ)
    • 6. 保守管理
      • 6.3 設定データの管理 6-7(376 ページ)
      • 6.7 任意コマンドの実行 6-23(392 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定 - 2.43 Web コンソールの設定 - 2.43.6.8 任意コマンドの実行 2-595(643 ページ)

NEC UNIVERGE IX2215 - IPv4 PPPoE 設定

以下のコマンドでインターネットに接続するために IPv4 PPPoE 設定をします。

NEC UNIVERGE IX2215 - PPPoE 設定コマンド
ppp profile PROFILE-NAME
  authentication myname NAME
  authentication password NAME PASSWORD

interface GigaEthernet0.1
  ppp binding PROFILE-NAME
  ip address ipcp
  ip napt enable
  ip tcp adjust-mss auto
  no shutdown

ppp profile で任意のプロファイル名(PROFILE-NAME)を作成し、ISP から提供された ID(NAME)とパスワード(PASSWORD)を設定します。ここで設定したプロファイル名はほかの設定(DHCP 設定PPPoE マルチセッション設定)でも使用します。

interface GigaEthernet0.x でインタフェースコンフィグモードへ移行、サブインタフェース(GigaEthernet0.x)に ppp profile で作成したプロファイル名を ppp binding で関連付けします。

インタフェースコンフィグモードでの ppp binding 以降は、ネットで紹介されていたコマンドをそのまま入力して設定しています。

PPPoE の接続状態は show pppoe status で確認できます。(参考情報

  • 実機演習資料(初級編)~UNIVERGE IX2215~(ix2k3k-learning-Ver.10.2_20.1.pdf)
    • (2)演習 1 PPPoE 回線でのインターネット接続 - PPPoE インタフェースの設定(46 ページ)
  • 取扱説明書(UM-IX2000-ver10.7-1.pdf)
    • 5 ネットワーク設定例 - PPPoE 設定例 5-9(271 ページ)
  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 7. PPP 編 - PPP
      • PPP プロファイルの作成/変更(入力形式 ppp profile PROFILE-NAME) 7-18(140 ページ)
      • 送信する認証名の設定(入力形式 authentication myname NAME) 7-4(126 ページ)
      • 認証名に対するパスワードの設定(入力形式 authentication password NAME PASSWORD) 7-5(127 ページ)
    • 3. インタフェース編 - インタフェース
      • インタフェースコンフィグモードへの移行(入力形式 interface INTERFACE-NAME) 3-5(37 ページ)
      • インタフェース停止(入力形式 shutdownno shutdown) 3-5(37 ページ)
    • 7. PPP 編 - PPP - PPP プロファイルの割り当て(入力形式 ppp binding PROFILE-NAME) 7-18(140 ページ)
    • 8. IPv4 編 - IPv4
      • インタフェースアドレス設定(入力形式 ip address ipcp) 8-9(160 ページ)
      • TCP-MSS 調整機能の設定(入力形式 ip tcp adjust-mss auto) 8-15(166 ページ)
    • 8. IPv4 編 - NAPT - NAPT の開始(入力形式 ip napt enable) 8-36(187 ページ)
    • 7. PPP 編 - PPPoE - 状態表示(入力形式 show pppoe status [INTERFACE]) 7-28(149 ページ)
  • Web 設定マニュアル(WM-ver10.7-1.pdf)
    • 4. 詳細設定 - 4.3 WAN - 4.3.1 プロバイダの設定 4-34(229 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定
      • 2.12 PPPoE の設定 2-121(169 ページ)
      • 2.16 IPv4 の設定 - 2.16.4 TCP MSS 調整 2-185(233 ページ)
      • 2.19 NAT/NAPT の設定 - 2.19.2 NAPT の設定 - 2.19.2.1 NAPT の設定 2-218(266 ページ)
      • 2.43 Web コンソールの設定 - 2.43.8 詳細設定 - 2.43.8.8 プロバイダの設定 2-604(652 ページ)
  • 設定事例集(IX1-3K-EX-10.7.pdf)
    • 9. PPPoE 設定
      • 9.1 PPPoE で端末型接続を行う 9-2(149ページ)
      • 9.3 TCP MSS 調整機能を使用する 9-5(152 ページ)

NEC UNIVERGE IX2215 - PPPoE MTU 値設定

以下のコマンドで PPPoE の MTU 値を設定します。

NEC UNIVERGE IX2215 - MTU 設定コマンド
interface GigaEthernet0.1
  ip mtu 1454

回線サービスによって MTU 値は決まっています。必須設定ではありませんが、私の環境では MTU 値を設定しておくことにします。

  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 3. インタフェース編 - インタフェース - インタフェースコンフィグモードへの移行(入力形式 interface INTERFACE-NAME) 3-5(37 ページ)
    • 8. IPv4 編 - IPv4 - MTU 変更(入力形式 ip mtu MUT) 8-11(162 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定 - 2.16 IPv4 の設定 - 2.16.4 TCP MSS 調整 2-185(233 ページ)
  • 設定事例集(IX1-3K-EX-10.7.pdf)
    • 9. PPPoE 設定 - 9.3 TCP MSS 調整機能を使用する 9-5(152 ページ)

NEC UNIVERGE IX2215 - ヘアピン NAT 設定

以下のコマンドでヘアピン NAT を設定します。

NEC UNIVERGE IX2215 - ヘアピン NAT 設定コマンド
interface GigaEthernet0.1
  ip napt hairpinning

家庭用ルーターではヘアピン NAT 機能がない機種が多いかと思いますので、この辺はさすが業務用ルーターといったところです。なおペアピン NAT は 1 インタフェースのみしか設定できません。

  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 3. インタフェース編 - インタフェース - インタフェースコンフィグモードへの移行(入力形式 interface INTERFACE-NAME) 3-5(37 ページ)
    • 8. IPv4 編 - NAPT - ヘアピン NAT の設定(入力形式 ip napt hairpinning) 8-37(188 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定
      • 2.19 NAT/NAPT の設定 - 2.19.2 NAPT の設定 - 2.19.2.8 ヘアピン NAT の設定 2-225(273 ページ)
      • 2.43 Web コンソールの設定 - 2.43.8 詳細設定 - 2.43.8.8 プロバイダの設定 2-604(652 ページ)

NEC UNIVERGE IX2215 - NAPT キャッシュサイズ設定

以下のコマンドで任意の NAPT キャッシュサイズを設定できます。UNIVERGE IX2215 では NAPT キャッシュサイズは最大値の 250000 まで設定できますが、デフォルト値は 65535 もあるので今回は設定していません。

NEC UNIVERGE IX2215 - NAPT キャッシュサイズ設定コマンド例
interface GigaEthernet0.1
  ip napt translation max-entries 250000

家庭用ルーターとは違い非常に大きな NAPT キャッシュを備えていますので、ルーターの仕様による NAT 溢れの心配はほぼないでしょう。

  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 3. インタフェース編 - インタフェース - インタフェースコンフィグモードへの移行(入力形式 interface INTERFACE-NAME) 3-5(37 ページ)
    • 8. IPv4 編 - NAPT - NAPT キャッシュの設定値変更(入力形式 ip napt translation max-entries MAX-ENTRIES) 8-38(189 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 1章 機能概要 - 1.2 諸元 - 1.2.2 IX2000/IX3000 ソフトウェア諸元 - 1.2.2.1 Ver.9.6 以降のソフトウェア諸元 - 「分類:NAPT、項目:キャッシュサイズ、IX2215 仕様:250000」 1-9(29 ページ)
    • 2章 ルータの設定 - 2.19 NAT/NAPT の設定 - 2.19.2 NAPT の設定
      • 2.19.2.1 NAPT の設定 2-218(266 ページ)
      • 2.19.2.6 NAPT キャッシュ数の制限の設定 - インタフェース単位での制限 2-224(272 ページ)

NEC UNIVERGE IX2215 - 静的 NAPT 設定

以下のコマンドで利用するネットサービスに応じて静的 NAPT(ポートフォワーディング)を設定します。

NEC UNIVERGE IX2215 - 静的 NAPT 設定コマンド
interface GigaEthernet0.1
  ip napt enable
  ip napt static GigaEthernet0.1 1
  ip napt static 192.168.xxx.xxx tcp xxxxx
  ip napt static 192.168.xxx.xxx udp xxxxx

対象機器の IP アドレスの後に tcpudp を指定してポート番号をセットします。

ip napt static GigaEthernet0.1 1 の最後の 1 は ICMP のプロトコル番号です。

IPv4 PPPoE 設定ip napt enable が設定済みであれば省略できます。

  • 実機演習資料(初級編)~UNIVERGE IX2215~(ix2k3k-learning-Ver.10.2_20.1.pdf)
    • (2)演習 1 PPPoE 回線でのインターネット接続 - NAPT テーブルの表示(56 ページ)
  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 3. インタフェース編 - インタフェース - インタフェースコンフィグモードへの移行(入力形式 interface INTERFACE-NAME) 3-5(37 ページ)
    • 8. IPv4 編 - NAPT - 静的 NAPT の設定(入力形式 ip napt static { INSIDE-ADDR | INTERFACE } PROTOCOL PORT-RANGE) 8-38(189 ページ)
  • Web 設定マニュアル(WM-ver10.7-1.pdf)
    • 4. 詳細設定 - 4.3 WAN - 4.3.2 静的 NAPT の設定 4-34(229 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定 - 2.19 NAT/NAPT の設定 - 2.19.2 NAPT の設定 - 2.19.2.4 静的 NAPT(Static NAPT)の設定 2-222(270 ページ)

NEC UNIVERGE IX2215 - ルーティング設定

以下のコマンドでインターネット接続のためのデフォルトルートを設定します。

NEC UNIVERGE IX2215 - ルーティング設定コマンド
ip route default GigaEthernet0.1

複数のサブインタフェース(interface GigaEthernet0.1 ~ GigaEthernet0.32)設定がある環境の場合注意点があります。

例えばデフォルトルート ip route default GigaEthernet0.1 の設定で IPv4 PPPoE 設定 設定済み interface GigaEthernet0.1shutdownPPPoE 切断)した場合、interface GigaEthernet0.1 以外に設定したサブインタフェースの IP アドレスからインターネット接続はできません。

この場合 PPPoE 切断していないサブインターフェース、例えば interface GigaEthernet0.2 があれば、デフォルトルート(ルーティング)設定を ip route default GigaEthernet0.2 に変更することで接続できるようになります。

  • 実機演習資料(初級編)~UNIVERGE IX2215~(ix2k3k-learning-Ver.10.2_20.1.pdf)
    • (2)演習 1 PPPoE 回線でのインターネット接続 - ルーティング設定設定(47 ページ)
  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 8. IPv4 編 - IPv4 - スタティックルート追加(入力形式 ip route default INTERFACE) 8-14(165 ページ)

NEC UNIVERGE IX2215 - パスワード暗号化設定

以下のコマンドで show running-config コマンドなどで表示されるパスワードを暗号化します。

NEC UNIVERGE IX2215 - パスワード暗号化設定コマンド
service password-encryption
  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 2. グローバルコンフィグ編 - グローバルコンフィグ - パスワード暗号化設定(入力形式 service password-encryption) 2-5(17 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定 - 2.2 システムの設定 - 2.2.2 パスワード情報の暗号化表示設定 2-10(58 ページ)

NEC UNIVERGE IX2215 - PPPoE 切断

以下のコマンドで PPPoE 接続を切断できます。

NEC UNIVERGE IX2215 - PPPoE 切断コマンド
interface GigaEthernet0.1
  shutdown

interface GigaEthernet0.x でインタフェースコンフィグモードへ移行、PPPoE 設定 したサブインタフェース(GigaEthernet0.x)に対して shutdown を入力するだけです。

接続したい場合は no shutdown を入力します。

PPPoE マルチセッション設定セッション数の上限数 から PPPoE 設定 だけしたり、任意のタイミングでセッションの接続・切断したい場合にも no shutdownshutdown コマンドを使います。

  • 取扱説明書(UM-IX2000-ver10.7-1.pdf)
    • 5 ネットワーク設定例 - PPPoE 設定例 - PPPoE 接続の切断 5-11(273 ページ)
  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 3. インタフェース編 - インタフェース
      • インタフェースコンフィグモードへの移行(入力形式 interface INTERFACE-NAME) 3-5(37 ページ)
      • インタフェース停止(入力形式 shutdownno shutdown) 3-5(37 ページ)

NEC UNIVERGE IX2215 - ロギング設定

以下のコマンドでロギングを設定をします。

NEC UNIVERGE IX2215 - ロギング設定コマンド
logging buffered 4096
logging subsystem all warn
logging timestamp timeofday

特にこだわりはないので こちらのロギング設定内容 をそのまま利用します。

  • 実機演習資料(初級編)~UNIVERGE IX2215~(ix2k3k-learning-Ver.10.2_20.1.pdf)
    • (1)基本操作(IX2215)
      • ログの収集(1)(39 ページ)
      • ログの収集(2)(40 ページ)
    • (2)演習 1 PPPoE 回線でのインターネット接続 - その他設定と設定保存(48 ページ)
  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 32. 保守編 - ログ情報 - ロギング
      • ロギングバッファの設定(入力形式 logging buffered [BUFFER-SIZE]) 32-17(758 ページ)
      • サブシステムメッセージ表示の設定(入力形式 logging subsystem SUBSYSTEM SEVERITY) 32-18(759 ページ)
      • タイムスタンプの設定(入力形式 logging timestamp { timeofday | uptime | datetime }) 32-20(761 ページ)
  • Web 設定マニュアル(WM-ver10.7-1.pdf)
    • 4. 詳細設定 - 4.1 基本設定 - 4.1.4 保守の設定 4-10(205 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 7章 遠隔設定と監視 - 7.4 ロギング 7-18(918 ページ)

NEC UNIVERGE IX2215 - NTP 設定

以下のコマンドで NTP を設定します。

NEC UNIVERGE IX2215 - NTP 設定コマンド
ntp server 210.173.160.27
ntp server 210.173.160.57
ntp server 210.173.160.87
ntp retry 10
ntp interval 86400

ntp server の IP アドレスは インターネットマルチフィード(MFEED)時刻情報提供サービス for Public が提供しているものです。

  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 26. NTP/SNTP 編 - NTP/SNTP
      • NTP 時刻同期間隔の設定(入力形式 ntp interval POLL-INTERVAL) 26-3(692 ページ)
      • NTP 同期リトライ回数の設定(入力形式 ntp retry RETRY-COUNTS) 26-4(693 ページ)
      • 同期をとる NTP サーバの設定(入力形式 ntp server ADDRESS) 26-5(694 ページ)
  • Web 設定マニュアル(WM-ver10.7-1.pdf)
    • 4. 詳細設定 - 4.1 基本設定 - 4.1.3 時刻の設定 4-8(203 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定 - 2.26 NTP の設定 2-355(403 ページ)

NEC UNIVERGE IX2215 - UFS キャッシュ設定

以下のコマンドで UFS キャッシュを設定します。

NEC UNIVERGE IX2215 - UFS キャッシュ設定コマンド
ip ufs-cache enable
ip ufs-cache max-entries 20000

ufs-cache max-entries の適切な数値について詳しく言及している情報を見つけられなかったので、ネット上でよく見かける 20000 という数値にとりあえず設定しています。

  • 実機演習資料(初級編)~UNIVERGE IX2215~(ix2k3k-learning-Ver.10.2_20.1.pdf)
    • (2)演習 1 PPPoE 回線でのインターネット接続 - その他設定と設定保存(48 ページ)
  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 8. IPv4 編 - IPv4
      • UFS キャッシュの有効(入力形式 ip ufs-cache enable) 8-16(167 ページ)
      • UFS キャッシュエントリ数設定(入力形式 ip ufs-cache max-entries SIZE) 8-17(168 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定 - 2.55 UFS キャッシュの設定 2-704(752 ページ)

NEC UNIVERGE IX2215 - DNS サーバ(IPv4)とプロキシ DNS 設定

以下のコマンドで DNS サーバ(IPv4)とプロキシ DNS を設定します。

NEC UNIVERGE IX2215 - DNS サーバ(IPv4)とプロキシ DNS 設定コマンド
ip name-server 1.1.1.1
ip name-server 1.0.0.1

proxy-dns ip enable
proxy-dns ip query-response 20
proxy-dns ip query-interval 1
proxy-dns interface GigaEthernet0.1 ignore
proxy-dns server 1.1.1.1 priority 254
proxy-dns server 1.0.0.1 priority 254

ここでは proxy-dns ip query-responseproxy-dns ip query-interval は最小値を設定していますが、特に理由はありません。この辺について言及している情報が見つからなかったので、設定する意味はないかもしれません。

ip name-serverproxy-dns server には Cloudflare(クラウドフレア)の無料 DNS キャッシュサーバサービスの IP アドレス(優先 DNS サーバ 1.1.1.1 と代替 DNS サーバ 1.0.0.1) を設定しています。

proxy-dns server で設定する priority は優先順位です。設定した値が高いサーバに問い合わせを優先します。値が同じ場合は登録した順番に従います。

上の例では priority は同じ 254 していますが、先に 1.1.1.1 を登録してあれば、次に登録した 1.0.0.1 より優先されることになります。

必須ではありませんが、プロバイダーの DNS サーバは使いたくないので proxy-dns interface GigaEthernet0.1 ignore を設定しています。ignore を入れることで指定したインタフェースから取得した DNS サーバアドレスを使用しません。

show proxy-dns で登録している DNS サーバと優先順位が確認できます。

  • 取扱説明書(UM-IX2000-ver10.7-1.pdf)
    • 5 ネットワーク設定例 - PPPoE 設定例 - 4 DNS サーバの設定 5-11(273 ページ)
  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 25. DNS 編 - プロキシ DNS
      • DNS サーバの動的取得インタフェースの設定(入力形式 proxy-dns interface INTERFACE [ignore]) 25-3(670 ページ)
      • DNS サーバのアドレス登録(入力形式 proxy-dns server IPv4ADDRESS [priority PRIORITY]) 25-3(670 ページ)
      • IPv4 プロキシ DNS の有効化(入力形式 proxy-dns ip enable) 25-4(671 ページ)
      • IPv4 DNS 要求パケット送信間隔の設定(入力形式 proxy-dns ip query-interval INTERVAL) 25-4(671 ページ)
      • IPv4 DNS 応答パケット待ち時間の設定(入力形式 proxy-dns ip query-response TIME) 25-4(671 ページ)
      • プロキシDNS 情報の表示(入力形式 show proxy-dns [ ip | ipv6 ]) 25-7(674 ページ)
    • 25. DNS 編 - DNS リゾルバ - DNS サーバ(IPv4)登録(入力形式 ip name-server ADDRESS) 25-13(680 ページ)
  • Web 設定マニュアル(WM-ver10.7-1.pdf)
    • 4. 詳細設定 - 4.3 WAN - 4.3.1 プロバイダの設定 4-34(229 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2.43 Web コンソールの設定 - 2.43.8 詳細設定 - 2.43.8.8 プロバイダの設定 2-604(652 ページ)
  • 設定事例集(IX1-3K-EX-10.7.pdf)
    • 9. PPPoE 設定 - 9.1 PPPoE で端末型接続を行う 9-2(149 ページ)

NEC UNIVERGE IX2215 - IP パケットフィルタリング設定

セキュリティ対策として以下のコマンドで IP パケットフィルタリングを設定します。

コマンド設定内容は こちら で紹介しているものと同じで一部コマンドを追加しています。

NEC UNIVERGE IX2215 - IP パケットフィルタリング設定コマンド
ip access-list all-pass option optimize
ip access-list all-pass permit ip src any dest any
ip access-list in_out-block option optimize
ip access-list in_out-block deny tcp src any sport any dest any dport eq 135
ip access-list in_out-block deny udp src any sport any dest any dport eq 135
ip access-list in_out-block deny tcp src any sport any dest any dport eq 137
ip access-list in_out-block deny udp src any sport any dest any dport eq 137
ip access-list in_out-block deny udp src any sport any dest any dport eq 138
ip access-list in_out-block deny tcp src any sport any dest any dport eq 139
ip access-list in_out-block deny tcp src any sport any dest any dport eq 445
ip access-list in_out-block deny udp src any sport any dest any dport eq 445
ip access-list mynetwork option optimize
ip access-list mynetwork permit ip src 192.168.xxx.xxx/xx dest any
ip access-list r-list1 option optimize
ip access-list r-list1 deny ip src 10.0.0.0/8 dest any
ip access-list r-list1 deny ip src 172.16.0.0/12 dest any
ip access-list r-list1 deny ip src 192.168.0.0/16 dest any
ip access-list str-block option optimize
ip access-list str-block deny udp src any sport any dest any dport eq 161
ip access-list svr-block deny tcp src any sport any dest any dport eq 1
ip access-list svr-block deny udp src any sport any dest any dport eq 1
ip access-list svr-block deny tcp src any sport any dest any dport eq 11
ip access-list svr-block deny udp src any sport any dest any dport eq 11
ip access-list svr-block deny tcp src any sport any dest any dport eq 15
ip access-list svr-block deny udp src any sport any dest any dport eq 15
ip access-list svr-block deny tcp src any sport any dest any dport eq 20
ip access-list svr-block deny udp src any sport any dest any dport eq 20
ip access-list svr-block deny tcp src any sport any dest any dport eq 21
ip access-list svr-block deny udp src any sport any dest any dport eq 21
ip access-list svr-block deny tcp src any sport any dest any dport eq 23
ip access-list svr-block deny udp src any sport any dest any dport eq 23
ip access-list svr-block deny tcp src any sport any dest any dport eq 67
ip access-list svr-block deny udp src any sport any dest any dport eq 67
ip access-list svr-block deny tcp src any sport any dest any dport eq 68
ip access-list svr-block deny udp src any sport any dest any dport eq 68
ip access-list svr-block deny tcp src any sport any dest any dport eq 69
ip access-list svr-block deny udp src any sport any dest any dport eq 69
ip access-list svr-block deny tcp src any sport any dest any dport eq 70
ip access-list svr-block deny udp src any sport any dest any dport eq 70
ip access-list svr-block deny tcp src any sport any dest any dport eq 79
ip access-list svr-block deny udp src any sport any dest any dport eq 79
ip access-list svr-block deny tcp src any sport any dest any dport eq 87
ip access-list svr-block deny udp src any sport any dest any dport eq 87
ip access-list svr-block deny tcp src any sport any dest any dport eq 95
ip access-list svr-block deny udp src any sport any dest any dport eq 95
ip access-list svr-block deny tcp src any sport any dest any dport eq 111
ip access-list svr-block deny udp src any sport any dest any dport eq 111
ip access-list svr-block deny tcp src any sport any dest any dport eq 144
ip access-list svr-block deny udp src any sport any dest any dport eq 144
ip access-list svr-block deny tcp src any sport any dest any dport eq 161
ip access-list svr-block deny tcp src any sport any dest any dport eq 162
ip access-list svr-block deny udp src any sport any dest any dport eq 162
ip access-list svr-block deny tcp src any sport any dest any dport eq 177
ip access-list svr-block deny udp src any sport any dest any dport eq 177
ip access-list svr-block deny tcp src any sport any dest any dport eq 220
ip access-list svr-block deny udp src any sport any dest any dport eq 220
ip access-list svr-block deny tcp src any sport any dest any dport eq 512
ip access-list svr-block deny udp src any sport any dest any dport eq 512
ip access-list svr-block deny tcp src any sport any dest any dport eq 513
ip access-list svr-block deny udp src any sport any dest any dport eq 513
ip access-list svr-block deny tcp src any sport any dest any dport eq 514
ip access-list svr-block deny udp src any sport any dest any dport eq 514
ip access-list svr-block deny tcp src any sport any dest any dport eq 515
ip access-list svr-block deny udp src any sport any dest any dport eq 515
ip access-list svr-block deny tcp src any sport any dest any dport eq 517
ip access-list svr-block deny udp src any sport any dest any dport eq 517
ip access-list svr-block deny tcp src any sport any dest any dport eq 518
ip access-list svr-block deny udp src any sport any dest any dport eq 518
ip access-list svr-block deny tcp src any sport any dest any dport eq 520
ip access-list svr-block deny udp src any sport any dest any dport eq 520
ip access-list svr-block deny tcp src any sport any dest any dport eq 540
ip access-list svr-block deny udp src any sport any dest any dport eq 540
ip access-list svr-block deny tcp src any sport any dest any dport eq 1025
ip access-list svr-block deny udp src any sport any dest any dport eq 1025
ip access-list svr-block deny tcp src any sport any dest any dport eq 2000
ip access-list svr-block deny udp src any sport any dest any dport eq 2000
ip access-list svr-block deny tcp src any sport any dest any dport eq 2049
ip access-list svr-block deny udp src any sport any dest any dport eq 2049
ip access-list svr-block deny tcp src any sport any dest any dport eq 2766
ip access-list svr-block deny udp src any sport any dest any dport eq 2766
ip access-list svr-block deny tcp src any sport any dest any dport range 6000 6063
ip access-list svr-block deny udp src any sport any dest any dport range 6000 6063
ip access-list svr-block deny tcp src any sport any dest any dport eq 6257
ip access-list svr-block deny udp src any sport any dest any dport eq 6257
ip access-list svr-block deny tcp src any sport any dest any dport eq 6665
ip access-list svr-block deny udp src any sport any dest any dport eq 6665
ip access-list svr-block deny tcp src any sport any dest any dport eq 6666
ip access-list svr-block deny udp src any sport any dest any dport eq 6666
ip access-list svr-block deny tcp src any sport any dest any dport eq 6667
ip access-list svr-block deny udp src any sport any dest any dport eq 6667
ip access-list svr-block deny tcp src any sport any dest any dport eq 6668
ip access-list svr-block deny udp src any sport any dest any dport eq 6668
ip access-list svr-block deny tcp src any sport any dest any dport eq 6669
ip access-list svr-block deny udp src any sport any dest any dport eq 6669
ip access-list svr-block deny tcp src any sport any dest any dport eq 6699
ip access-list svr-block deny udp src any sport any dest any dport eq 6699
ip access-list svr-block deny tcp src any sport any dest any dport eq 7743
ip access-list svr-block deny udp src any sport any dest any dport eq 7743
ip access-list svr-block deny tcp src any sport any dest any dport eq 12345
ip access-list svr-block deny udp src any sport any dest any dport eq 12345
ip filter forced-reassembly

interface GigaEthernet0.1
  ip filter in_out-block 1 in
  ip filter svr-block 100 in
  ip filter r-list1 110 in
  ip filter all-pass 65000 in
  ip filter in_out-block 1 out
  ip filter mynetwork 50 out
  ip filter svr-block 100 out
  ip filter r-list1 110 out
  ip filter all-pass 65000 out

ip access-list mynetwork permit ip src 192.168.xxx.xxx/xx dest any の部分(13行目)で利用しているネットワーク構成に応じて、通過を許可する IP アドレスとサブネットマスク長を設定します。ここの入力内容を間違えたり登録を忘れたりするとインターネット接続ができません。(入力例:ip access-list mynetwork permit ip src 192.168.1.0/24 dest any

ちなみに こちら で紹介しているすべての IPv4 アクセスリスト(ip access-list)をそのまま登録するとエラーが発生して一部登録できません。

原因は ip access-list svr-block deny tcp src any sport any dest any sport eq 68 とあるところで、これは sport が 2つあるためでした。

ip access-list svr-block deny tcp src any sport any dest any dport eq 68(34行目)に修正(sportdport)することで正常に登録できました。

各アクセスリスト名に option optimize を入れてアクセスリストの検索処理を最適化しています。

IPv4 アクセスリストの登録をしたら interface GigaEthernet0.x でインタフェースコンフィグモードへ移行、サブインタフェース(GigaEthernet0.x)に ip filter コマンドで IPv4 パケットフィルタを設定します。

ip filter コマンドの後に登録したアクセスリスト名(ACCESS-LIST-NAME)とシーケンス No.(SEQUENCE-NUMBER)と方向(DIRECTION)を適用します。ここでの入力を間違えたり忘れたりするとインターネットの接続ができなかったり、意図したネットワーク設定にならない可能性があります。

  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 13. セキュリティ編 - IPv4 パケットフィルタ
      • IPv4 パケットフィルタの設定(入力形式 ip filter ACCESS-LIST-NAME SEQUENCENUMBER DIRECTION) 13-3(375 ページ)
      • IPv4 強制リアセンブリの設定(入力形式 ip filter forced-reassembly) 13-3(375 ページ)
    • 24. アクセスリスト編 - IPv4 アクセスリスト
      • IPv4 アクセスリストの登録(IP)(入力形式 ip access-list NAME { permit | deny } ip src SRC dest DEST) 24-3(644 ページ)
      • IPv4 アクセスリストの登録(TCP・UDP)(入力形式 ip access-list NAME { permit | deny } { tcp | udp } src SRC sport OPERATOR PORT dest DEST dport OPERATOR PORT) 24-3~4(644~645 ページ)
      • IPv4 アクセスリストの最適化設定(入力形式 ip access-list NAME option optimize) 24-8(649 ページ)
  • Web 設定マニュアル(WM-ver10.7-1.pdf)
    • 4. 詳細設定 - 4.3 WAN - 4.3.3 WAN フィルタの設定(Ver10.3 以降の機能) 4-38(233 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定 - 2.30 パケットフィルタの設定 2-414(462 ページ)

NEC UNIVERGE IX2215 - QoS マーキング設定

以下のコマンドで QoS マーキングを設定します。

設定内容は こちら で紹介している内容をそのまま登録しています。

NEC UNIVERGE IX2215 - QoS マーキング設定コマンド
ip access-list ipv4_udp_range permit udp src any sport range 1024 65535 dest any dport range 1024 65535

class-map match-any udp-port
  match ip access-list ipv4_udp_range normal

policy-map output-policy
  class udp-port
    set ip dscp 48

interface GigaEthernet2.0
  service-policy enable
  service-policy input output-policy
  service-policy output output-policy

参考サイト 先では policy-mapclass class-localclass class-default が表示してありますが、以下のコマンドで登録した時点で自動的に設定されます。(入力不要)

policy-map output-policy
  class udp-port
    set ip dscp 48

QoS の登録方法は複雑ですので、こちらこちら で QoS の設定や動作状態を確認しておきましょう。

  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 3. インタフェース編 - インタフェース - インタフェースコンフィグモードへの移行(入力形式 interface INTERFACE-NAME) 3-5(37 ページ)
    • 14. OoS 編 - QoS
      • 帯域制御/優先制御の有効設定(入力形式 service-policy enable) 14-4(493 ページ)
      • 受信パケットに対するポリシーマップ適用(入力形式 service-policy input POLICY-MAP-NAME) 14-4(493 ページ)
      • 送信パケットに対するポリシーマップ適用(入力形式 service-policy output POLICY-MAP-NAME) 14-4(493 ページ)
    • 14. OoS 編 - ポリシーマップ
      • クラスの作成/設定(入力形式 class CLASS-NAME) 14-8(497 ページ)
      • ポリシーマップの作成/設定(入力形式 policy-map POLICY-MAP-NAME) 14-8(497 ページ)
      • IPv4 DSCP 設定(入力形式 set ip dscp IP-DSCP) 14-10(499 ページ)
      • 帯域制御/優先制御の状態表示(入力形式 show policy-map interface [INTERFACE-NAME]) 14-10(501 ページ)
      • 帯域制御/優先制御の初期化(入力形式 clear policy-map interface [INTERFACE-NAME]) 14-13(502 ページ)
    • 14. OoS 編 - クラスマップ
      • クラスマップの作成/設定(入力形式 class-map [match-all | match-any] CLASS-MAPNAME) 14-16(505 ページ)
      • クラス分類条件設定(IPv4)(入力形式 match ip access-list ACCESS-LIST-NAME [high|medium|normal|low|suba|sub-b|sub-c|sub-d]) 14-17(506 ページ)
    • 24. アクセスリスト編 - IPv4 アクセスリスト
      • IPv4 アクセスリストの登録(TCP・UDP)(入力形式 ip access-list NAME { permit | deny } { tcp | udp } src SRC sport OPERATOR PORT dest DEST dport OPERATOR PORT) 24-3~4(644~645 ページ)
      • IPv4 アクセスリストの最適化設定(入力形式 ip access-list NAME option optimize) 24-8(649 ページ)
  • Web 設定マニュアル(WM-ver10.7-1.pdf)
    • 4. 詳細設定 - 4.3 WAN - 4.3.6 QoS の設定 4-62(257 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定 - 2.40 QoS の設定 2-534(582 ページ)
  • 設定事例集(IX1-3K-EX-10.7.pdf)
    • 12. QoS 設定 12-1(182 ページ)

NEC UNIVERGE IX2215 - DHCP 設定

以下のコマンドで DHCP を設定します。IP パケットフィルタリング設定 がある場合はあわせて通過を許可する IP アドレスを設定する必要がある点に注意してください。

NEC UNIVERGE IX2215 - DHCP 設定コマンド
ip dhcp enable
ip dhcp excluded-address 192.168.1.98 192.168.1.127

ip dhcp profile dhcp1
  assignable-range 192.168.1.96 192.168.1.191
  dns-server 192.168.1.1
  lease-time 86400
  fixed-assignment 192.168.1.96 xx:xx:xx:xx:xx:xx
  fixed-assignment 192.168.1.97 xx:xx:xx:xx:xx:xx
  fixed-assignment 192.168.1.190 xx:xx:xx:xx:xx:xx
  fixed-assignment 192.168.1.191 xx:xx:xx:xx:xx:xx

interface GigaEthernet2.0
  ip dhcp binding dhcp1

上記の DHCP 設定例は 192.168.1.96 ~ 192.168.1.191 の範囲内で IP アドレスを自動で割り振り、そのうち 192.168.1.98 ~ 192.168.1.127 の IP アドレス範囲を除外とする設定です。

ip dhcp profile で DHCP プロファイルを作成して、DHCP コンフィグモードに移行します。

DHCP コンフィグモードでは assignable-range で DHCP アドレスの割り当て範囲を設定、dns-server はルータの IP アドレスを指定、fixed-assignment は DHCP アドレス範囲内にアドレス固定割り当て機器があれば IP アドレスと MAC アドレスをセットで指定します。

ip dhcp excluded-address で DHCP 除外 IP アドレス範囲を設定できます。

interface GigaEthernet2.0(GE2)でインタフェースコンフィグモードへ移行、基本インタフェース(GigaEthernet2.0)に ip dhcp profile で作成した DHCP プロファイル名を ip dhcp binding で 関連付けします。

NEC UNIVERGE IX2215 - DHCP 設定コマンド(IP パケットフィルタリング設定 あり)
ip dhcp enable
ip dhcp excluded-address 192.168.1.98 192.168.1.127

ip access-list mynetwork permit ip src 192.168.1.96/27 dest any
ip access-list mynetwork permit ip src 192.168.1.128/26 dest any

ip dhcp profile dhcp1
  assignable-range 192.168.1.96 192.168.1.191
  dns-server 192.168.1.1
  lease-time 86400
  fixed-assignment 192.168.1.96 xx:xx:xx:xx:xx:xx
  fixed-assignment 192.168.1.97 xx:xx:xx:xx:xx:xx
  fixed-assignment 192.168.1.190 xx:xx:xx:xx:xx:xx
  fixed-assignment 192.168.1.191 xx:xx:xx:xx:xx:xx

interface GigaEthernet2.0
  ip dhcp binding dhcp1

IP パケットフィルタリング設定 がある場合は ip access-list で通過を許可する IP アドレスとサブネットマスク長を忘れずにセットで設定します。

  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 3. インタフェース編 - インタフェース - インタフェースコンフィグモードへの移行(入力形式 interface INTERFACE-NAME) 3-5(37 ページ)
    • 8. IPv4 編 - DHCP
      • DHCP アドレスの割り当て範囲設定(入力形式 assignable-range LOW-ADDRESS HIGHADDRESS) 8-46(197 ページ)
      • DHCP DNS サーバのアドレス設定(入力形式 dns-server PRIMARY-ADDRESS) 8-47(198 ページ)
      • 固定割り当てアドレスの追加(入力形式 fixed-assignment IP-ADDRESS HW-ADDRESS) 8-47(198 ページ)
      • DHCP プロファイルの割り当て(入力形式 ip dhcp binding PROFILE-NAME) 8-48(199 ページ)
      • DHCP サーバの有効設定(入力形式 ip dhcp enable) 8-48(199 ページ)
      • 除外アドレス範囲の追加(入力形式 ip dhcp excluded-address LOW-ADDRESS HIGH-ADDRESS) 8-48(199 ページ)
      • DHCP コンフィグモードへの移行(入力形式 ip dhcp profile PROFILE-NAME) 8-49(200 ページ)
      • DHCP リースタイム設定(入力形式 lease-time {TIME | infinite}) 8-50(201 ページ)
    • 24. アクセスリスト編 - IPv4 アクセスリスト - IPv4 アクセスリストの登録(IP)(入力形式 ip access-list NAME { permit | deny } ip src SRC dest DEST) 24-3(644 ページ)
  • Web 設定マニュアル(WM-ver10.7-1.pdf)
    • 4. 詳細設定 - 4.2 LAN - 4.2.2 DHCP サーバの設定 4-22(217 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定 - 2.18 DHCP の設定 2-207(255 ページ)
    • 2章 ルータの設定 - 2.43 Web コンソールの設定 - 2.43.8 詳細設定 - 2.43.8.7 DHCP サーバの設定 2-604(652 ページ)
  • 設定事例集(IX1-3K-EX-10.7.pdf)
    • 9. PPPoE 設定 - 9.1 PPPoE で端末型接続を行う 9-2(149ページ)

NEC UNIVERGE IX2215 - LAN・USB ポート停止設定

以下のコマンドで使わない LAN・USB ポートの停止設定ができます。

この設定はブラウザから「詳細設定」にある「デバイスの設定」からでもポート停止ができます。

NEC UNIVERGE IX2215 - LAN・USB ポート停止設定コマンド
device GigaEthernet1
  shutdown

device GigaEthernet2
  port 2 shutdown
  port 3 shutdown
  port 4 shutdown
  port 5 shutdown
  port 6 shutdown
  port 7 shutdown
  port 8 shutdown

device USB0
  shutdown

device コマンドでデバイスコンフィグモードへ移行、各デバイス名またはポート番号(port x)に対して shutdown を入力するだけです。

上記コマンドは GE1 ポートと GE2(SW-HUB)の 2~8 番ポート、USB ポートを停止します。この設定で稼働するポートは GE0 ポートと GE2(SW-HUB)の 1 番ポートの状態です。

ポート停止解除したい場合は no shutdown を入力します。

  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 3. インタフェース編 - インタフェース
      • デバイスコンフィグモードへの移行(入力形式 device DEVICE-NAME) 3-4(36 ページ)
      • インタフェース停止(入力形式 shutdownno shutdown) 3-6(38 ページ)
  • Web 設定マニュアル(WM-ver10.7-1.pdf)
    • 4. 詳細設定 - 4.6 デバイス 4-111(306 ページ)

NEC UNIVERGE IX2215 - NetMeister 登録・設定

NetMeister の登録をすれば、以下のコマンドでオンライン上でルーターの保守管理ができるようになります。

NEC UNIVERGE IX2215 - NetMeister 設定コマンド
nm ip enable
nm account GROUPID password { plain | secret } PASSWORD

NetMeister の特長としてオンラインでルーターのファームウェアの直接アップデートができるようになります。そのため、ダウンロードしてファームウェアを手動でアップデートする手間を省くことができます。

  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 22. ネットワーク管理編 - NetMeister
      • アカウントの設定(入力形式 nm account GROUPID password { plain | secret } PASSWORD) 22-3(593 ページ)
      • NetMeister クライアント機能の有効化(入力形式 nm { ip | ipv6 } enable) 22-4(594 ページ)
  • Web 設定マニュアル(WM-ver10.7-1.pdf)
    • 4. 詳細設定 - 4.1 基本設定 - 4.1.5 NetMeister の設定 4-14(209 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定 - 2.48 NetMeister の設定 2-656(704 ページ)
  • 設定事例集(IX1-3K-EX-10.7.pdf)
    • 38. NetMeister の設定 38-1(1074 ページ)

NEC UNIVERGE IX2215 - PPPoE マルチセッション設定

以下のコマンドは PPPoE マルチセッションの設定例です。ポリシールーティング機能を使って PPPoE マルチセッションを設定します。(回線契約によって PPPoE セッション数の上限値があるため注意(関連記事))

こちらは試行錯誤して設定した内容のため不要な設定や間違いがあるかもしれません。

NEC UNIVERGE IX2215 - PPPoE マルチセッション設定コマンド
ip route default GigaEthernet0.1

ip access-list mynetwork1 permit ip src 192.168.1.2/32 dest any
ip access-list mynetwork2 permit ip src 192.168.1.3/32 dest any

route-map rmap permit 10
  match ip address access-list mynetwork1
  set interface GigaEthernet0.1

route-map rmap permit 20
  match ip address access-list mynetwork2
  set interface GigaEthernet0.2

ppp profile PROFILE-NAME1
  authentication myname NAME1
  authentication password NAME1 PASSWORD1

ppp profile PROFILE-NAME2
  authentication myname NAME2
  authentication password NAME2 PASSWORD2

interface GigaEthernet2.0
  ip policy route-map rmap

interface GigaEthernet0.1
  ppp binding PROFILE-NAME1
  ip address ipcp
  ip napt enable
  ip napt hairpinning
  ip napt static GigaEthernet0.1 1
  no shutdown

interface GigaEthernet0.2
  ppp binding PROFILE-NAME2
  ip address ipcp
  ip napt enable
  ip napt static GigaEthernet0.2 1
  no shutdown

今回設定した PPPoE マルチセッションでは ルーティング設定(デフォルトルート)ip route default GigaEthernet0.1 は必要でした。私の環境ではこの設定がないと PPPoE マルチセッション接続ができませんでした。

IPv4 PPPoE 設定 をします。ここでは 2セッション接続のため ppp profile PROFILE-NAME1ppp profile PROFILE-NAME2 を作成して ISP から提供された ID・パスワードをそれぞれ設定(ISP の ID・パスワードは 1セッションまで、セッション数に応じて契約が必要:関連記事)します。(14~20行目)

interface GigaEthernet0.1interface GigaEthernet0.2 でインタフェースコンフィグモードに移行し、それぞれのサブインタフェースに ppp profile で作成したプロファイル名を ppp binding で関連付けします。(25~38行目)

ちなみに ヘアピン NAT 設定ip napt hairpinning は 1 インタフェースのみでしか設定できません。上のコマンド例では interface GigaEthernet0.1ヘアピン NAT を設定した場合、interface GigaEthernet0.2 には設定できません。(29行目)

ip access-list でポリシールーティングの対象とする(セッション別に接続する)機器の IP アドレスとサブネットマスク長を登録します。ここではセッション別に mynetwork1mynetwork2 にわけて作成・登録しています。なお、ip access-listIP パケットフィルタリング設定 でも使うコマンドです。(3~4行目)

route-map でルートマップを作成(名前は任意、ここでは rmap を作成)、permit で次の match 条件に適合した場合にルートマップを適用対象、シーケンス番号としてここでは 1020 に設定してルートマップコンフィグモードへと移行します。ルートマップコンフィグモードでは set コマンドと match コマンドが実行可能となります。(6行目と 10行目)

それぞれのルートマップコンフィグモードでは match ip address で、ip access-list で作成したポリシールーティング対象機器のアクセスリスト名を指定します。(7行目と 11行目)

set interface でポリシールーティングにおける送信インタフェースを指定します。指定する送信インタフェースは IPv4 PPPoE 設定 のサブインタフェースです。ここでは GigaEthernet0.1GigaEthernet0.2 です。(8行目と 12行目)

続けて interface GigaEthernet2.0(GE2)でインタフェースコンフィグモードへ移行、ルートマップを GE2(基本インタフェース ・・・ GigaEthernet2.0)に適用します。IPv4 ポリシールーティング設定 ip policy route-map で、route-map で作成した rmap を指定してポリシールーティングを有効にします。(22~23行目)

ルートマップコンフィグモードで設定した set コマンドと match コマンドで、シーケンス番号順に条件に一致した指定・範囲内の IP アドレス機器をセッション別に接続します。(6~12行目)

以上で PPPoE マルチセッション設定およびポリシールーティングによる PPPoE のセッション別接続設定は完了です。

注意点として デフォルトルート(ルーティング)設定 ip route default GigaEthernet0.1 の設定でサブインタフェース interface GigaEthernet0.1shutdownPPPoE 切断)した場合、interface GigaEthernet0.2 に該当する IP アドレスからインターネット接続はできなくなるようです。

この場合 デフォルトルート(ルーティング)設定ip route default GigaEthernet0.2(PPPoE 切断していないサブインタフェース)に変更することで接続できるようになります。

PPPoE マルチセッションが確立しているどうかは show pppoe status で確認します。(参考情報

  • コマンドリファレンスマニュアル(CRM-ver10.7-1.pdf)
    • 24. アクセスリスト編 - IPv4 アクセスリスト - IPv4 アクセスリストの登録(IP)(入力形式 ip access-list NAME { permit | deny } ip src SRC dest DEST) 24-3(644 ページ)
    • 8. IPv4 編 - IPv4 - IPv4 ポリシールーティング設定(入力形式 ip policy route-map ROUTE-MAP-NAME) 8-12(163 ページ)
    • 23. 高度な経路制御編 - ルートマップ
      • ルートマップ追加/設定(入力形式 route-map ROUTE-MAP-NAME [permit | deny] [SEQUENCE]) 23-6(631 ページ)
      • インタフェース指定(入力形式 set interface INTERFACE) 23-7(632 ページ)
      • ルートマップ状態表示(入力形式 show route-map [ROUTE-MAP-NAME]) 23-10(635 ページ)
      • 統計情報のリセット(入力形式 clear route-map [ROUTE-MAP-NAME]) 23-11(636 ページ)
    • 7. PPP 編 - PPPoE - 状態表示(入力形式 show pppoe status [INTERFACE]) 7-28(149 ページ)
  • 機能説明書(FD-ver10.7.pdf)
    • 2章 ルータの設定 - 2.22 ルーティング設定 - 2.22.7 ポリシールーティング 2-313(361 ページ)
  • 設定事例集(IX1-3K-EX-10.7.pdf)
    • 11. ポリシールーティング設定 - 11-1(170 ページ)

NEC UNIVERGE IX2215 設定例

以下、UNIVERGE IX2215 で設定したコマンド内容 を使って、接続する機器が固定 IP アドレスと DHCP の2種類のパターンにおける UNIVERGE IX2215 ネットワーク環境設定例を公開します。いずれも PPPoE マルチセッション設定 および IP パケットフィルタリング設定QoS マーキング設定 をしてあります。

NEC 業務用ルーター UNIVERGE IX2215(中古)自宅用ルーター IPv4 PPPoE ネットワーク設定メモ、NEC UNIVERGE IX2215 設定例、NEC UNIVERGE IX2215 - IPv4 PPPoE 設定データ、DHCP を使わない固定 IP アドレスで PC を使う場合のネットワーク設定、インターネット プロトコル バージョン 4(TCP/IP)のプロパティ画面で「次の IP アドレスを使う」にある IP アドレス、サブネット マスク、デフォルト ゲートウェイを入力、デフォルト ゲートウェイはルーターの IP アドレス、「次の DNS サーバーのアドレスを使う」にある優先 DNS サーバーもルーターの IP アドレスを入力

接続する機器が固定 IP アドレスのみの場合の UNIVERGE IX2215 ネットワーク環境設定例です。

この設定例では ip access-list コマンドのアクセスリスト名 mynetwork1mynetwork2 に同じ固定 IP アドレスを設定しています。

PPPoE マルチセッション設定どちらかのセッションに切り替え ても、同じ固定 IP アドレスのまま切り替え先のセッションに接続できます。

ただし、PPPoE マルチセッション で同時に複数のセッションを確立して、対応するアクセスリストに登録した固定 IP アドレスが同じ場合、どちらかのセッションにしか接続しません。

そのため、PPPoE セッションを手動で切断してから、接続したい PPPoE セッションを手動で接続 するといった手順と デフォルトルート(ルーティング)設定 ip route default GigaEthernet0.x の変更が必要です。

別の方法として ip access-list コマンドのアクセスリスト名に PPPoE マルチセッション 別に IP アドレスを登録しておくという方法があります。複数のセッションを確立している状態でも、接続機器のネットワーク設定の固定 IP アドレスをアクセスリストで登録した内容に都度手動で変更することで、接続先を切り替えることができます。

NEC UNIVERGE IX2215 - 設定データ(固定 IP アドレス構成例)
service password-encryption
!
hostname HOSTNAME
!
logging buffered 4096
logging subsystem all warn
logging timestamp timeofday
!
username USER-NAME password { plain [MODE] | hash } PASSWORD [LEVEL]
!
ntp server 210.173.160.27
ntp server 210.173.160.57
ntp server 210.173.160.87
ntp retry 10
ntp interval 86400
!
!
ip ufs-cache max-entries 20000
ip ufs-cache enable
ip route default GigaEthernet0.1
ip access-list all-pass option optimize
ip access-list all-pass permit ip src any dest any
ip access-list in_out-block option optimize
ip access-list in_out-block deny tcp src any sport any dest any dport eq 135
ip access-list in_out-block deny udp src any sport any dest any dport eq 135
ip access-list in_out-block deny tcp src any sport any dest any dport eq 137
ip access-list in_out-block deny udp src any sport any dest any dport eq 137
ip access-list in_out-block deny udp src any sport any dest any dport eq 138
ip access-list in_out-block deny tcp src any sport any dest any dport eq 139
ip access-list in_out-block deny tcp src any sport any dest any dport eq 445
ip access-list in_out-block deny udp src any sport any dest any dport eq 445
ip access-list ipv4_udp_range option optimize
ip access-list ipv4_udp_range permit udp src any sport range 1024 65535 dest any dport range 1024 65535
ip access-list mynetwork1 option optimize
ip access-list mynetwork1 permit ip src 192.168.1.2/32 dest any
ip access-list mynetwork2 option optimize
ip access-list mynetwork2 permit ip src 192.168.1.2/32 dest any
ip access-list r-list1 option optimize
ip access-list r-list1 deny ip src 10.0.0.0/8 dest any
ip access-list r-list1 deny ip src 172.16.0.0/12 dest any
ip access-list r-list1 deny ip src 192.168.0.0/16 dest any
ip access-list str-block option optimize
ip access-list str-block deny udp src any sport any dest any dport eq 161
ip access-list svr-block deny tcp src any sport any dest any dport eq 1
ip access-list svr-block deny udp src any sport any dest any dport eq 1
ip access-list svr-block deny tcp src any sport any dest any dport eq 11
ip access-list svr-block deny udp src any sport any dest any dport eq 11
ip access-list svr-block deny tcp src any sport any dest any dport eq 15
ip access-list svr-block deny udp src any sport any dest any dport eq 15
ip access-list svr-block deny tcp src any sport any dest any dport eq 20
ip access-list svr-block deny udp src any sport any dest any dport eq 20
ip access-list svr-block deny tcp src any sport any dest any dport eq 21
ip access-list svr-block deny udp src any sport any dest any dport eq 21
ip access-list svr-block deny tcp src any sport any dest any dport eq 23
ip access-list svr-block deny udp src any sport any dest any dport eq 23
ip access-list svr-block deny tcp src any sport any dest any dport eq 67
ip access-list svr-block deny udp src any sport any dest any dport eq 67
ip access-list svr-block deny tcp src any sport any dest any dport eq 68
ip access-list svr-block deny udp src any sport any dest any dport eq 68
ip access-list svr-block deny tcp src any sport any dest any dport eq 69
ip access-list svr-block deny udp src any sport any dest any dport eq 69
ip access-list svr-block deny tcp src any sport any dest any dport eq 70
ip access-list svr-block deny udp src any sport any dest any dport eq 70
ip access-list svr-block deny tcp src any sport any dest any dport eq 79
ip access-list svr-block deny udp src any sport any dest any dport eq 79
ip access-list svr-block deny tcp src any sport any dest any dport eq 87
ip access-list svr-block deny udp src any sport any dest any dport eq 87
ip access-list svr-block deny tcp src any sport any dest any dport eq 95
ip access-list svr-block deny udp src any sport any dest any dport eq 95
ip access-list svr-block deny tcp src any sport any dest any dport eq 111
ip access-list svr-block deny udp src any sport any dest any dport eq 111
ip access-list svr-block deny tcp src any sport any dest any dport eq 144
ip access-list svr-block deny udp src any sport any dest any dport eq 144
ip access-list svr-block deny tcp src any sport any dest any dport eq 161
ip access-list svr-block deny tcp src any sport any dest any dport eq 162
ip access-list svr-block deny udp src any sport any dest any dport eq 162
ip access-list svr-block deny tcp src any sport any dest any dport eq 177
ip access-list svr-block deny udp src any sport any dest any dport eq 177
ip access-list svr-block deny tcp src any sport any dest any dport eq 220
ip access-list svr-block deny udp src any sport any dest any dport eq 220
ip access-list svr-block deny tcp src any sport any dest any dport eq 512
ip access-list svr-block deny udp src any sport any dest any dport eq 512
ip access-list svr-block deny tcp src any sport any dest any dport eq 513
ip access-list svr-block deny udp src any sport any dest any dport eq 513
ip access-list svr-block deny tcp src any sport any dest any dport eq 514
ip access-list svr-block deny udp src any sport any dest any dport eq 514
ip access-list svr-block deny tcp src any sport any dest any dport eq 515
ip access-list svr-block deny udp src any sport any dest any dport eq 515
ip access-list svr-block deny tcp src any sport any dest any dport eq 517
ip access-list svr-block deny udp src any sport any dest any dport eq 517
ip access-list svr-block deny tcp src any sport any dest any dport eq 518
ip access-list svr-block deny udp src any sport any dest any dport eq 518
ip access-list svr-block deny tcp src any sport any dest any dport eq 520
ip access-list svr-block deny udp src any sport any dest any dport eq 520
ip access-list svr-block deny tcp src any sport any dest any dport eq 540
ip access-list svr-block deny udp src any sport any dest any dport eq 540
ip access-list svr-block deny tcp src any sport any dest any dport eq 1025
ip access-list svr-block deny udp src any sport any dest any dport eq 1025
ip access-list svr-block deny tcp src any sport any dest any dport eq 2000
ip access-list svr-block deny udp src any sport any dest any dport eq 2000
ip access-list svr-block deny tcp src any sport any dest any dport eq 2049
ip access-list svr-block deny udp src any sport any dest any dport eq 2049
ip access-list svr-block deny tcp src any sport any dest any dport eq 2766
ip access-list svr-block deny udp src any sport any dest any dport eq 2766
ip access-list svr-block deny tcp src any sport any dest any dport range 6000 6063
ip access-list svr-block deny udp src any sport any dest any dport range 6000 6063
ip access-list svr-block deny tcp src any sport any dest any dport eq 6257
ip access-list svr-block deny udp src any sport any dest any dport eq 6257
ip access-list svr-block deny tcp src any sport any dest any dport eq 6665
ip access-list svr-block deny udp src any sport any dest any dport eq 6665
ip access-list svr-block deny tcp src any sport any dest any dport eq 6666
ip access-list svr-block deny udp src any sport any dest any dport eq 6666
ip access-list svr-block deny tcp src any sport any dest any dport eq 6667
ip access-list svr-block deny udp src any sport any dest any dport eq 6667
ip access-list svr-block deny tcp src any sport any dest any dport eq 6668
ip access-list svr-block deny udp src any sport any dest any dport eq 6668
ip access-list svr-block deny tcp src any sport any dest any dport eq 6669
ip access-list svr-block deny udp src any sport any dest any dport eq 6669
ip access-list svr-block deny tcp src any sport any dest any dport eq 6699
ip access-list svr-block deny udp src any sport any dest any dport eq 6699
ip access-list svr-block deny tcp src any sport any dest any dport eq 7743
ip access-list svr-block deny udp src any sport any dest any dport eq 7743
ip access-list svr-block deny tcp src any sport any dest any dport eq 12345
ip access-list svr-block deny udp src any sport any dest any dport eq 12345
ip filter forced-reassembly
!
!
!
!
!
!
!
!
!
!
!
ip name-server 1.1.1.1
ip name-server 1.0.0.1
!
proxy-dns ip enable
proxy-dns ip query-response 20
proxy-dns ip query-interval 1
proxy-dns interface GigaEthernet0.1 ignore
proxy-dns interface GigaEthernet0.2 ignore
proxy-dns server 1.1.1.1 priority 254
proxy-dns server 1.0.0.1 priority 254
!
telnet-server ip enable
!
http-server username USER-NAME
http-server ip enable
!
nm ip enable
nm account GROUPID password { plain | secret } PASSWORD
!
!
route-map rmap permit 10
  match ip address access-list mynetwork1
  set interface GigaEthernet0.1
!
route-map rmap permit 20
  match ip address access-list mynetwork2
  set interface GigaEthernet0.2
!
ppp profile PROFILE-NAME1
  authentication myname NAME1
  authentication password NAME1 PASSWORD1
!
ppp profile PROFILE-NAME2
  authentication myname NAME2
  authentication password NAME2 PASSWORD2
!
class-map match-any udp-port
  match ip access-list ipv4_udp_range normal
!
policy-map output-policy
  class udp-port
    set ip dscp 48
  class class-local
  class class-default
!
device GigaEthernet0
!
device GigaEthernet1
  shutdown
!
device GigaEthernet2
  port 2 shutdown
  port 3 shutdown
  port 4 shutdown
  port 5 shutdown
  port 6 shutdown
  port 7 shutdown
  port 8 shutdown
!
device BRI0
  isdn switch-type hsd128k
!
device USB0
  shutdown
!
interface GigaEthernet0.0
  no ip address
  shutdown
!
interface GigaEthernet1.0
  no ip address
  shutdown
!
interface GigaEthernet2.0
  ip address 192.168.1.1/24
  ip policy route-map rmap
  service-policy enable
  service-policy input output-policy
  service-policy output output-policy
  no shutdown
!
interface BRI0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!
interface USB-Serial0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!
interface GigaEthernet0.1
  encapsulation pppoe
  auto-connect
  ppp binding pppoe1
  ip address ipcp
  ip mtu 1454
  ip tcp adjust-mss auto
  ip napt enable
  ip napt hairpinning
  ip napt static GigaEthernet0.1 1
  ip napt static 192.168.1.2 tcp xxxxx
  ip napt static 192.168.1.2 udp xxxxx
  ip filter in_out-block 1 in
  ip filter svr-block 100 in
  ip filter r-list1 110 in
  ip filter all-pass 65000 in
  ip filter in_out-block 1 out
  ip filter mynetwork1 50 out
  ip filter svr-block 100 out
  ip filter r-list1 110 out
  ip filter all-pass 65000 out
  no shutdown
!
interface GigaEthernet0.2
  encapsulation pppoe
  auto-connect
  ppp binding pppoe2
  ip address ipcp
  ip mtu 1454
  ip tcp adjust-mss auto
  ip napt enable
  ip napt static GigaEthernet0.2 1
  ip napt static 192.168.1.2 tcp xxxxx
  ip napt static 192.168.1.2 udp xxxxx
  ip filter in_out-block 1 in
  ip filter svr-block 100 in
  ip filter r-list1 110 in
  ip filter all-pass 65000 in
  ip filter in_out-block 1 out
  ip filter mynetwork2 50 out
  ip filter svr-block 100 out
  ip filter r-list1 110 out
  ip filter all-pass 65000 out
  shutdown
!
interface Loopback0.0
  no ip address
!
interface Null0.0
  no ip address
!
NEC 業務用ルーター UNIVERGE IX2215(中古)自宅用ルーター IPv4 PPPoE ネットワーク設定メモ、NEC UNIVERGE IX2215 設定例、NEC UNIVERGE IX2215 - IPv4 PPPoE 設定データ、ルーター DHCP 有効化での PC ネットワーク設定、インターネット プロトコル バージョン 4(TCP/IP)のプロパティ画面で「IP アドレスを自動的に取得する」と「DNS サーバーのアドレスを自動的に取得する」を設定(IP アドレスの入力は不要)

接続する機器が DHCP の場合の UNIVERGE IX2215 ネットワーク環境設定例です。

上記固定 IP アドレスによるネットワーク設定例に DHCP の設定 が加わっている内容となります。同じネットワークセグメント内に固定 IP アドレスと重複しない IP アドレスを割り振っている設定のため、ルーターを並列接続してもインターネットに接続できる設定となっています。(関連記事

こちらも PPPoE マルチセッション を利用する場合は ip access-list コマンドのアクセスリスト名で、DHCP で設定した範囲内の IP アドレス機器を設定して管理することになります。

NEC UNIVERGE IX2215 - 設定データ(DHCP 構成例)
service password-encryption
!
hostname HOSTNAME
!
logging buffered 4096
logging subsystem all warn
logging timestamp timeofday
!
username USER-NAME password { plain [MODE] | hash } PASSWORD [LEVEL]
!
ntp server 210.173.160.27
ntp server 210.173.160.57
ntp server 210.173.160.87
ntp retry 10
ntp interval 86400
!
!
ip ufs-cache max-entries 20000
ip ufs-cache enable
ip route default GigaEthernet0.1
ip dhcp enable
ip dhcp excluded-address 192.168.1.98 192.168.1.127
ip access-list all-pass option optimize
ip access-list all-pass permit ip src any dest any
ip access-list in_out-block option optimize
ip access-list in_out-block deny tcp src any sport any dest any dport eq 135
ip access-list in_out-block deny udp src any sport any dest any dport eq 135
ip access-list in_out-block deny tcp src any sport any dest any dport eq 137
ip access-list in_out-block deny udp src any sport any dest any dport eq 137
ip access-list in_out-block deny udp src any sport any dest any dport eq 138
ip access-list in_out-block deny tcp src any sport any dest any dport eq 139
ip access-list in_out-block deny tcp src any sport any dest any dport eq 445
ip access-list in_out-block deny udp src any sport any dest any dport eq 445
ip access-list ipv4_udp_range option optimize
ip access-list ipv4_udp_range permit udp src any sport range 1024 65535 dest any dport range 1024 65535
ip access-list mynetwork1 option optimize
ip access-list mynetwork1 permit ip src 192.168.1.96/27 dest any
ip access-list mynetwork1 permit ip src 192.168.1.128/26 dest any
ip access-list mynetwork2 option optimize
ip access-list mynetwork2 permit ip src 192.168.1.96/27 dest any
ip access-list mynetwork2 permit ip src 192.168.1.128/26 dest any
ip access-list r-list1 option optimize
ip access-list r-list1 deny ip src 10.0.0.0/8 dest any
ip access-list r-list1 deny ip src 172.16.0.0/12 dest any
ip access-list r-list1 deny ip src 192.168.0.0/16 dest any
ip access-list str-block option optimize
ip access-list str-block deny udp src any sport any dest any dport eq 161
ip access-list svr-block deny tcp src any sport any dest any dport eq 1
ip access-list svr-block deny udp src any sport any dest any dport eq 1
ip access-list svr-block deny tcp src any sport any dest any dport eq 11
ip access-list svr-block deny udp src any sport any dest any dport eq 11
ip access-list svr-block deny tcp src any sport any dest any dport eq 15
ip access-list svr-block deny udp src any sport any dest any dport eq 15
ip access-list svr-block deny tcp src any sport any dest any dport eq 20
ip access-list svr-block deny udp src any sport any dest any dport eq 20
ip access-list svr-block deny tcp src any sport any dest any dport eq 21
ip access-list svr-block deny udp src any sport any dest any dport eq 21
ip access-list svr-block deny tcp src any sport any dest any dport eq 23
ip access-list svr-block deny udp src any sport any dest any dport eq 23
ip access-list svr-block deny tcp src any sport any dest any dport eq 67
ip access-list svr-block deny udp src any sport any dest any dport eq 67
ip access-list svr-block deny tcp src any sport any dest any dport eq 68
ip access-list svr-block deny udp src any sport any dest any dport eq 68
ip access-list svr-block deny tcp src any sport any dest any dport eq 69
ip access-list svr-block deny udp src any sport any dest any dport eq 69
ip access-list svr-block deny tcp src any sport any dest any dport eq 70
ip access-list svr-block deny udp src any sport any dest any dport eq 70
ip access-list svr-block deny tcp src any sport any dest any dport eq 79
ip access-list svr-block deny udp src any sport any dest any dport eq 79
ip access-list svr-block deny tcp src any sport any dest any dport eq 87
ip access-list svr-block deny udp src any sport any dest any dport eq 87
ip access-list svr-block deny tcp src any sport any dest any dport eq 95
ip access-list svr-block deny udp src any sport any dest any dport eq 95
ip access-list svr-block deny tcp src any sport any dest any dport eq 111
ip access-list svr-block deny udp src any sport any dest any dport eq 111
ip access-list svr-block deny tcp src any sport any dest any dport eq 144
ip access-list svr-block deny udp src any sport any dest any dport eq 144
ip access-list svr-block deny tcp src any sport any dest any dport eq 161
ip access-list svr-block deny tcp src any sport any dest any dport eq 162
ip access-list svr-block deny udp src any sport any dest any dport eq 162
ip access-list svr-block deny tcp src any sport any dest any dport eq 177
ip access-list svr-block deny udp src any sport any dest any dport eq 177
ip access-list svr-block deny tcp src any sport any dest any dport eq 220
ip access-list svr-block deny udp src any sport any dest any dport eq 220
ip access-list svr-block deny tcp src any sport any dest any dport eq 512
ip access-list svr-block deny udp src any sport any dest any dport eq 512
ip access-list svr-block deny tcp src any sport any dest any dport eq 513
ip access-list svr-block deny udp src any sport any dest any dport eq 513
ip access-list svr-block deny tcp src any sport any dest any dport eq 514
ip access-list svr-block deny udp src any sport any dest any dport eq 514
ip access-list svr-block deny tcp src any sport any dest any dport eq 515
ip access-list svr-block deny udp src any sport any dest any dport eq 515
ip access-list svr-block deny tcp src any sport any dest any dport eq 517
ip access-list svr-block deny udp src any sport any dest any dport eq 517
ip access-list svr-block deny tcp src any sport any dest any dport eq 518
ip access-list svr-block deny udp src any sport any dest any dport eq 518
ip access-list svr-block deny tcp src any sport any dest any dport eq 520
ip access-list svr-block deny udp src any sport any dest any dport eq 520
ip access-list svr-block deny tcp src any sport any dest any dport eq 540
ip access-list svr-block deny udp src any sport any dest any dport eq 540
ip access-list svr-block deny tcp src any sport any dest any dport eq 1025
ip access-list svr-block deny udp src any sport any dest any dport eq 1025
ip access-list svr-block deny tcp src any sport any dest any dport eq 2000
ip access-list svr-block deny udp src any sport any dest any dport eq 2000
ip access-list svr-block deny tcp src any sport any dest any dport eq 2049
ip access-list svr-block deny udp src any sport any dest any dport eq 2049
ip access-list svr-block deny tcp src any sport any dest any dport eq 2766
ip access-list svr-block deny udp src any sport any dest any dport eq 2766
ip access-list svr-block deny tcp src any sport any dest any dport range 6000 6063
ip access-list svr-block deny udp src any sport any dest any dport range 6000 6063
ip access-list svr-block deny tcp src any sport any dest any dport eq 6257
ip access-list svr-block deny udp src any sport any dest any dport eq 6257
ip access-list svr-block deny tcp src any sport any dest any dport eq 6665
ip access-list svr-block deny udp src any sport any dest any dport eq 6665
ip access-list svr-block deny tcp src any sport any dest any dport eq 6666
ip access-list svr-block deny udp src any sport any dest any dport eq 6666
ip access-list svr-block deny tcp src any sport any dest any dport eq 6667
ip access-list svr-block deny udp src any sport any dest any dport eq 6667
ip access-list svr-block deny tcp src any sport any dest any dport eq 6668
ip access-list svr-block deny udp src any sport any dest any dport eq 6668
ip access-list svr-block deny tcp src any sport any dest any dport eq 6669
ip access-list svr-block deny udp src any sport any dest any dport eq 6669
ip access-list svr-block deny tcp src any sport any dest any dport eq 6699
ip access-list svr-block deny udp src any sport any dest any dport eq 6699
ip access-list svr-block deny tcp src any sport any dest any dport eq 7743
ip access-list svr-block deny udp src any sport any dest any dport eq 7743
ip access-list svr-block deny tcp src any sport any dest any dport eq 12345
ip access-list svr-block deny udp src any sport any dest any dport eq 12345
ip filter forced-reassembly
!
!
!
!
!
!
!
!
!
!
!
ip name-server 1.1.1.1
ip name-server 1.0.0.1
!
proxy-dns ip enable
proxy-dns ip query-response 20
proxy-dns ip query-interval 1
proxy-dns interface GigaEthernet0.1 ignore
proxy-dns interface GigaEthernet0.2 ignore
proxy-dns server 1.1.1.1 priority 254
proxy-dns server 1.0.0.1 priority 254
!
telnet-server ip enable
!
http-server username USER-NAME
http-server ip enable
!
nm ip enable
nm account GROUPID password { plain | secret } PASSWORD
!
!
route-map rmap permit 10
  match ip address access-list mynetwork1
  set interface GigaEthernet0.1
!
route-map rmap permit 20
  match ip address access-list mynetwork2
  set interface GigaEthernet0.2
!
ppp profile PROFILE-NAME1
  authentication myname NAME1
  authentication password NAME1 PASSWORD1
!
ppp profile PROFILE-NAME2
  authentication myname NAME2
  authentication password NAME2 PASSWORD2
!
ip dhcp profile dhcp1
  assignable-range 192.168.1.96 192.168.1.191
  dns-server 192.168.1.1
  lease-time 86400
  fixed-assignment 192.168.1.96 xx:xx:xx:xx:xx:xx
  fixed-assignment 192.168.1.97 xx:xx:xx:xx:xx:xx
  fixed-assignment 192.168.1.190 xx:xx:xx:xx:xx:xx
  fixed-assignment 192.168.1.191 xx:xx:xx:xx:xx:xx
!
class-map match-any udp-port
  match ip access-list ipv4_udp_range normal
!
policy-map output-policy
  class udp-port
    set ip dscp 48
  class class-local
  class class-default
!
device GigaEthernet0
!
device GigaEthernet1
  shutdown
!
device GigaEthernet2
  port 2 shutdown
  port 3 shutdown
  port 4 shutdown
  port 5 shutdown
  port 6 shutdown
  port 7 shutdown
  port 8 shutdown
!
device BRI0
  isdn switch-type hsd128k
!
device USB0
  shutdown
!
interface GigaEthernet0.0
  no ip address
  shutdown
!
interface GigaEthernet1.0
  no ip address
  shutdown
!
interface GigaEthernet2.0
  ip address 192.168.1.10/24
  ip dhcp binding dhcp1
  ip policy route-map rmap
  service-policy enable
  service-policy input output-policy
  service-policy output output-policy
  no shutdown
!
interface BRI0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!
interface USB-Serial0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!
interface GigaEthernet0.1
  encapsulation pppoe
  auto-connect
  ppp binding pppoe1
  ip address ipcp
  ip mtu 1454
  ip tcp adjust-mss auto
  ip napt enable
  ip napt hairpinning
  ip napt static GigaEthernet0.1 1
  ip napt static 192.168.1.96 tcp xxxxx
  ip napt static 192.168.1.96 udp xxxxx
  ip filter in_out-block 1 in
  ip filter svr-block 100 in
  ip filter r-list1 110 in
  ip filter all-pass 65000 in
  ip filter in_out-block 1 out
  ip filter mynetwork1 50 out
  ip filter svr-block 100 out
  ip filter r-list1 110 out
  ip filter all-pass 65000 out
  no shutdown
!
interface GigaEthernet0.2
  encapsulation pppoe
  auto-connect
  ppp binding pppoe2
  ip address ipcp
  ip mtu 1454
  ip tcp adjust-mss auto
  ip napt enable
  ip napt static GigaEthernet0.2 1
  ip napt static 192.168.1.96 tcp xxxxx
  ip napt static 192.168.1.96 udp xxxxx
  ip filter in_out-block 1 in
  ip filter svr-block 100 in
  ip filter r-list1 110 in
  ip filter all-pass 65000 in
  ip filter in_out-block 1 out
  ip filter mynetwork2 50 out
  ip filter svr-block 100 out
  ip filter r-list1 110 out
  ip filter all-pass 65000 out
  shutdown
!
interface Loopback0.0
  no ip address
!
interface Null0.0
  no ip address
!
関連記事